Logo
›
›vulnerability›CVE-2026-73070
Name
CVE-2026-73070
Source
NVD ( link)Debian ( link)
Description
Vim is an open source, command line text editor. Prior to 9.2.0842, the socket server backend in src/socketserver.c accepts unbounded client connections in socketserver_accept(), causing descriptors to overflow fd_set structures in src/channel.c and fixed-size struct pollfd arrays in src/os_unix.c, which allows a local process that can connect to the server socket to corrupt stack memory or terminate the Vim server. This issue is fixed in version 9.2.0842.
Published Date
Updated Date
Workaround
-

Analysis#


Affected Component
Analysis
vim
Exploitable

Vulnerability Ratings#


6.8
CVSSv4
5.5
CVSSv31
NaN
other

Others affected components#


Name
Project
Project Version
Version
Status
buildroot
2025.02.x
9.2.0943
Not Affected
buildroot
master
9.2.0943
Not Affected
openwrt
master
9.2.1014-r1
Not Affected
openwrt
openwrt-25.12
9.2.1014-r1
Not Affected
yocto
kirkstone
9.1.1683
Exploitable
yocto
master
9.2.0993
Not Affected
yocto
master
9.2.0993
Not Affected