Logo
›
›vulnerability›CVE-2026-73077
Name
CVE-2026-73077
Source
NVD ( link)Debian ( link)
Description
Vim is an open source, command line text editor. Prior to 9.2.0839, the runtime/ftplugin/sh.vim, runtime/ftplugin/zsh.vim, and runtime/ftplugin/ps1.vim filetype plugins pass attacker-controlled Visual-mode selections from K through keywordprg commands without safely separating shell arguments. fnameescape() and PATH_ESC_CHARS do not neutralize shell metacharacters before ShKeywordPrg, ZshKeywordPrg, or GetHelp invokes bash, zsh, or PowerShell, allowing arbitrary operating-system commands to execute with the privileges of the user running Vim. This issue is fixed in version 9.2.0839.
Published Date
Updated Date
Workaround
-

Analysis#


Affected Component
Analysis
vim
Exploitable

Vulnerability Ratings#


8.4
CVSSv4
7.8
CVSSv31
NaN
other

Others affected components#


Name
Project
Project Version
Version
Status
buildroot
2025.02.x
9.2.0943
Not Affected
buildroot
master
9.2.0943
Not Affected
openwrt
master
9.2.1014-r1
Not Affected
openwrt
openwrt-25.12
9.2.1014-r1
Not Affected
yocto
master
9.2.0993
Not Affected
yocto
master
9.2.0993
Not Affected
yocto
scarthgap
9.1.1683
Exploitable